Wer nach einer super Methode sucht um den DynDNS Service von IPv64.net mit einem Mikrotik Gerät aktuell zu halten, der bekommt hier ein kurzes Script aufgezeigt.

Das Script schaut sogar nach ob sich die IP-Adresse geändert hat und wenn ja dann wird ein Update an den IPv64.net Service geschickt. Somit werden sogar die Abfragen gegenüber dem Updater minimiert.

Die ersten drei Variablen sind von euch auszufüllen. Der Router muss das Internet Interface haben, hier z.B. das “pppoe_out1” Interface zur Einwahl mit einem DSL Modem. Die IPv64-Domain und der Token kommen aus eurem Useraccount.

Das Script trägt man einfach als Event beim Scheduler ein.

System -> Scheduler (Optimal als Zeit 5 Min. einstellen)

:local Mywan "pppoe_out1"
:local ipv64Domain "xxxxxx.ipv64.net"
:local Token "xxxxxxxxxxxxxxxxxxxx"
 
:local IpCurrentMe [/ip address get [find interface=$Mywan] address];
:local IpCurrentIPv64 [:put [:resolve $ipv64Domain]];
 
:for i from=( [:len $IpCurrentMe] - 1) to=0 do={
:if ( [:pick $IpCurrentMe $i] = "/") do={
:local NewIP [:pick $IpCurrentMe 0 $i];
:if ($IpCurrentIPv64 != $NewIP) do={
/tool fetch url="https://ipv64.net/update.php?key=$Token&domain=$ipv64Domain" keep-result=no
:log info "IPv64 Update: $ipv64Domain - $NewIP"
}
}
}

Aktuelle Bestseller von Mikrotik

Bestseller Nr. 1
Mikrotik hEX S Ethernet-Router, 10, 100,1000 MBit/s, 10/100/1000Base-T(X), Schwarz, 256 MB, 11 W, DC
Mikrotik hEX S Ethernet-Router, 10, 100,1000 MBit/s, 10/100/1000Base-T(X), Schwarz, 256 MB, 11 W, DC
Mikrotik hEX S Ethernet-Schnittstelle: Gigabit Ethernet.; Kabeltechnologie: 10/100/1000Base-T (X).
89,99 EUR
Bestseller Nr. 2
MikroTik Cloud Smart Switch 326-24G-2S+RM [24x Gigabit Ethernet, 2X SFP+]
MikroTik Cloud Smart Switch 326-24G-2S+RM [24x Gigabit Ethernet, 2X SFP+]
5902560364460; CSS326-24G-2S+RM; Netzwerkverwaltungsgeräte
273,16 EUR
AngebotBestseller Nr. 3
MikroTik CRS305-1G-4S+IN
MikroTik CRS305-1G-4S+IN
−19,65 EUR 150,34 EUR